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FileMaker 14 Specific features

FileMaker Pro and FileMaker Pro Advanced Specific Features for the Middle East and India

FileMaker Pro 14 and FileMaker Pro 14 Advanced is an enhanced version of the #1-selling easy-to-use
database software, adapted for the Middle East and India.

Use this guide to explore and understand the specific features of FileMaker for the Middle East and

India:
Contents
2 Support of Middle Eastern and Indian languages
Paragraph direction
Character Direction
Digits
7 Spelling Option
7 Layout of Middle Eastern Content
Controls
Mirror Layout
13 Sorting - Search/Find
16 FileMaker WebDirect

18 Diacritics and Ligatures
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Support of Middle Eastern and Indian languages

FileMaker Pro and FileMaker Pro Advanced provide enhanced support of Arabic & Hebrew as well as
Indic languages for Windows and Macintosh.

FileMaker Pro and FileMaker Pro Advanced come with enhanced options for entering and displaying
Middle Eastern and Indian texts and special settings for laying out these languages.

The paragraph and character directions are key elements for laying out Arabic or Hebrew texts.

Paragraph direction

It is important to understand and differentiate between the paragraph direction function and the
paragraph alignment function. Paragraph direction controls the order of multidirectional text inside
the paragraph. Paragraph alignment controls the placement of the whole line according to the left and
right boundaries.

Paragraph direction and alignment are independent. If your text is mainly Arabic or Hebrew, use a
“Right to Left” paragraph direction, otherwise, use the “Left to Right” option.

Left To Right Arabiq; Aalt peace S
Right to left Arabic et 2l peACE |

You can access this option via:
- The Formatting tool bar (available via the menu View>Formatting Bar)
- The Inspector>Appearance panel (available via the menu View>Inspector)

- The menu Format>Paragraph Direction

- The menu Format>Line Spacing>Other...
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Formatting tool bar
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Menu Format>Line Spacing>Other...

Paragraph a_ ‘ W
Alignment Indent Line Spacing
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@ Left to Right i@ Roman
71 Right to Left ) Mative

Format Menu

Font
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Style
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Text Color
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Character Direction

FileMaker automatically calculates the default character direction according to the language/script of
the character, the paragraph direction as well as the surrounding characters.

In a few cases, some characters may not be displayed in the right position. In order to force the
direction of the misplaced character, use the right-to-left or left-to-right character direction option
in the Text Format dialog box.

- Aright-to-left character belongs to a language/script which is read right-to-left (example: Arabic,
Hebrew, Persian).

- A left-to-right character belongs to a language/script which is read from left-to-right (example
English, French).

You can access this option via:
- The Inspector>Appearance panel (available via the menu View>Inspector), see page 2
- The menu Format>Conditional
- By right-clicking on a field

From the “Conditional Formatting” dialog, click “Add” to define a new condition.
Click on button “More Formatting”.

.

3 Style
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stess 12 - Bold Frree
TextColor: M+ Italic Subscript
Fil Color: = Strikeout Condense
Char Direction: | Right to Left g Smal !?aps Extend
Underline

Default
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Digits
FileMaker Pro and FileMaker Pro Advanced allow you to use different digits: roman and native.

For example:

4528967 t¢oyAdny

L] 1 2 3 4 H] & 7 8 9 Arabic disits

. \ ¥ r & o 1 v A q Hindi digits

You can access this option via:

- The Text Formatting toolbar (available from menu View>Formatting bar)

- The Inspector>Appearance panel (available via the menu View>Inspector), see page 3
- The menu Format>Line Spacing>Other...

Menu Format>Line Spacing>Other...

Also the default language option of the field should be coherent to the selected Digit Set option.
(File > Manage > Database then select your field and choose Options button)
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Spelling Option

FileMaker Pro and FileMaker Pro Advanced also include the support of the “cocoAspell” tool (Mac OS
X interface for Aspell) from Mac OS 10.4 for Arabic, Hebrew, Thai, Farsi, Vietnamese, Czech, Slovak,
Hungarian, Polish, Romanian, Slovenian, Croatian, Turkish, Estonian, Lithuanian, Latvian, Serbian,
Bulgarian, Ukrainian, Greek, Russian.

To use cocoAspell:
- Install cocoAspell using its installer
- Download the language pack (ftp://ftp.gnu.org/gnu/aspell/dict) from the FTP site.
- Once the archive is decompressed, copy the files into /Library/Application Support/CocoaSpell.

- The last step is to launch the preference panel (using System Preferences) and in preference
“Spelling” you choose which language you want to activate and which to deactivate.

- Restart FileMaker to see the activated languages.

Layout of Middle Eastern Content

FileMaker Pro and FileMaker Pro Advanced come with special settings for laying out right-to-left
content.

Controls

Each control can have right-to-left attributes such as alighment and direction.
- Dropdown list

- Dropdown calendar
- Edit box

- Popup menu

- Check box

- Radio button
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Portal setup

You can access this option via:

- The menu Insert>Portal
- The Inspector>Data panel (available via the menu View>Inspector)

Show related records from: [ Arabic_Glyphs ﬁ

["1Sart portal records
"1 Filter portal records

"] Allow deletion of portal records
[T Show vertical scroll bar

"] Reset scroll bar when exiting record

|[:] Use Right to Left Layout |

Format

Initial row: 1 Number of rows:
[ Alternate background fill:

(Canee) (06
)

Example of Portal:
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Data panel

i
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Dropdown list
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Button Bar

FileMaker Pro and FileMaker Pro Advanced come with a new feature that offers you a right to left
behavior for the button bar.

You can access this option from the ‘Button Bar Setup’ panel by double clicking on the button bar.

Button Bar Setup x
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Mirror Layout

FileMaker Pro and FileMaker Pro Advanced come with a new feature that offers you a mirror image of
your layout. This feature converts your layout from left-to-right to right-to-left.

You can access this option via:
- The menu Arrange -> Mirror Layout
- The contextual menu Arrange -> Mirror Layout

Scripts Tools  Window  He

Group Ctrl+R
Ungroup Ctrl+Shitt+R
Lock Chrl +AE+L
Unlock Ctrl + 280+ Shift+L
Britig to Eront Chrl +480E+]
Ering Forward Ctrl +Shift+[
Send to Back Chrl +40t+]
Send Backward Ctrl +5hift+]
Botate Ctrl +2t+R
Mirror Layout

Align »
Distribute »
Resize To »
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Find an example of this feature in the template below: before and after applying the Mirror Layout.

[ NewEstmate 4] Estimates New Customer

\ Summary  Follow Up Status Grand Total Date Estimate ‘ Hew Custorner | Company

D [&] e

|

| Summary  Follow Up Status Grand Total Date Accepted

B
£
g

| posal Code
| Country

v Contact Time:

= Note

Accepted Estimates $0.00 pending Estimates $0,00 n

New Customer Estimates (4 New Estimate

Company | New Customer | ‘ Estimate Date. grand Toml  smws FollowUp  Summary

Website .
First i
Last

Job Tite

Email [=]
Phone 1
Phone2
Fox | | v

Address 1 el ( Accepted Date Grand Toml  Sttus Followlp  Summary
Address 2 I
City ‘
State
Postal Code
Country J

Contct Time v

Note g

pending Estimates $0.00 accepeed Estmates $0.00

100 =& B Browse ¢ > il
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Sorting - Search/Find

FileMaker Pro and FileMaker Pro Advanced come with extra languages for the sorting and search/find
attributes which allow you to sort, search and find Middle Eastern and Indian text.

Find the list of available languages in FileMaker Pro and FileMaker Pro Advanced below:
- For the Middle East : Arabic, Hebrew and other languages such as Farsi
Note: for better results, search your data without diacritics.

- For India : Hindi, Marathi, Bengali, Panjabi, Gujarati, Tamil, Telugu, Kannada and Malayalam

- For Asia : Thai, Vietnamese
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To define the default sort language for indexing and sorting text, you simply open the “Options for
Field” box and click the appropriate options:

Options for Field “Venue Romanian ! e X
Slovenian

: Croatian
Auto-Enter | Validation
| | | T
Estonian
Global Storage Lithusnian
A field that uzes glo Latvian y one value that is
shared across all re Serbian (Latin) alsobe used az a
temporarystorage . |scTipts).
Bulgarian
Use global stora Flusgsian ds)
Ukrainian
Repeating Greek
Greek (Moced)
Maximum number o
Arabic =
Farsi
Indexing Hebrew
Indexing improves | pindi ations like finds
and supports funct Marathi and field
value unigueness a Bengali size and time
spent indexing. Panjabi
o Gujarati
Indexing: () MNon Tamil @ all
aut; Telugu as needed
Kannada -
Default language: | French E

Applies to text indexing, sorting, and default display font.

| oK || Cancel
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You can also select another language each time you sort data:

Slovak
Hungarian
Polish

Current Layout ("Event Details’) Homanian
Croatian
Turkish
Estonian
Lithuanian
Latvian
Serbian (Latin)

Bulgarian
Russian
Ukrainian

Greek

Greek {Mixed)

h. ©) Descending order I —

Li ) Custom order based on value list
arsi

Hebrew

[~| Reorder based on summary field Hindi
[¥] Override field's language for sort | French

[¥]Keep records in sorted order [ unsat | [ sot | [ cancel
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FileMaker WebDirect

FileMaker Pro et FileMaker Pro Advanced come with special settings for publishing databases on the
web.

You can share your database with users in a web browser, allowing them to find, browse, and modify

data with an English, Arabic, Hebrew interface as well as some other languages.

MNew Databasze...
Mew From Starter Solution...

Open... Ctrl+0
Open Remeote... Ctrl+Shift+ O
Open Recent L
Open Favorite L2
Cloze Ctrl+W

Manage L3

File Options... Share with FileMaker Clients...
Change Password... Enable CDBC/IDBC...
Configure for FileMaker WebDirect...

Print Setup...
Print... Ctrl+P

Import Records 4
Export Records...

Si

S r

5 Configure the security and visibility of a file to be viewed in FileMaker WebDirect. This file must be hosted by
R

Ey

FileMaker Server.

‘ Currently open files | FileMaker WebDirect access to file

| Assets.

; File: Assets
@ Al users
() Specify users by privilege set | Speafy.. |
) No users

Don't display on Fi WebDirect h

[ ok ][ caneel ]_
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FileMaker templates seen in a web browser

¢« > C L@]_?2.16.0.99/fmi/iwp/cgi?fdb=Event%20Management&floadframes

New Event
Event Title
[New Event
Verue
Date
jendi 29 mars 2012
Description
|Address
City
Postal Code
E =
Untitled
Title
[Ontitied |
Location
IND Location ‘
Date )
onetn 700
Start Time End Time
| [«]] [+]
| [~]] []
Refated Meetings
-
= Untitled 20003112 -
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Diacritics and Ligatures

FileMaker Pro et FileMaker Pro Advanced come with special settings to preserve ligatures and diacrit-
ics.

When exporting and saving databases in pdf format the diacritics will be properly placed over the
consonants, both horizontally and vertically. The ligatures will be also correctly rendered.

See the example below:

Fichier Edition Affichage Insertion Format Enregistrements Scripts Outils  Fenétre Aide
[~

..1;

1 19 /361 =
LBl s @it & .
Enregistrements ' rouves flen s Aﬁil:h’ertou‘l Mouvel a"‘ t S il IE ist it Rec%her

[1]
(I3

=
A

(Control panel

O Color ®Fruit O Vegetables OFaun O HNatur
i i
. Pineapple unl_:llj
“ Strawberry :d J‘ :)3
@ Tangerine ¢ é’ "é
- Orange J;ﬁj)j
- i
& sal &g

Note: for better results, search your data without diacritics.




